ERROR MESSAGE

Highlighted
New Member

ERROR MESSAGE

this keeps happening and I can't move forward

 

Review your form below, click on each field marked "Required" or "Invalid Format", and complete or correct your information.

 

The following error occurred in the ActionFormService.GetActionReviewContent: Jint.Parser.ParserException: Line 13: Illegal return statement at Jint.Parser.JavaScriptParser.ThrowError(Token token, String messageFormat, Object[] arguments) at Jint.Parser.JavaScriptParser.ThrowErrorTolerant(Token token, String messageFormat, Object[] arguments) at Jint.Parser.JavaScriptParser.ParseReturnStatement() at Jint.Parser.JavaScriptParser.ParseStatement() at Jint.Parser.JavaScriptParser.ParseSourceElement() at Jint.Parser.JavaScriptParser.ParseSourceElements() at Jint.Parser.JavaScriptParser.ParseProgram() at Jint.Parser.JavaScriptParser.Parse(String code, ParserOptions options) at Jint.Parser.JavaScriptParser.Parse(String code) at Jint.Engine.Execute(String source) at Infosnap.Secure.GlobalServices.ScriptingService.Execute(String code, Dictionary`2 contextItems) at Infosnap.Secure.Domain.Code.Function.Execute(List`1 arguments) at Infosnap.Secure.Domain.Forms.SmartFormUpdate.Evaluate(NameValueCollection formData, IDictionary`2 sessionData, Function function) at Infosnap.Secure.FamilyPortal.Controllers.Services.ActionFormsService.GetActionReviewContent(Int32 publishedActionId, String culture, Int32 page)

5 Replies
Highlighted
Senior

Re: ERROR MESSAGE

This error message is common if a special character such as <, >, /, _, - is added to the registration form or within the parent portal. If you are receiving the "Unexpected Problem" error message at the payment stage of the form, this may indicate a special character was entered on that page that is preventing the form from submitting. I recommend making sure that no special characters have been entered on that page, in order to submit the enrollment form successfully.  


I have provided an article here that will walk you through the troubleshooting steps when receiving the error message accessing your PowerSchool Enrollment account or form.



Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

Highlighted
Padawan

Re: ERROR MESSAGE

I changed my password with no special characters, my login has one because it is an email address and I still get the error.

Highlighted
Senior

Re: ERROR MESSAGE

Hi @nelso343

 

If you are still having trouble accessing the Enrollment form, I recommend accessing the form in a different web browser (for example, if you are using Internet Explorer, try accessing the form in Google Chrome or Mozilla Firefox). 

 

I also suggest clearing the cache, browser history, and cookies of your internet browser. I have provided an article here that will help walk you through the process of clearing the cache and cookies of your internet browser. You can access the article through this direct link.

 

If you are unable to access the Enrollment form after going through these steps, I recommend reaching out to the Enrollment Family support team by clicking on this direct link who should be able to assist you in submitting the Enrollment form to your school district.



Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

Highlighted
Recruit

Re: ERROR MESSAGE

I have tried every solution listed and nothing works. I tried IE, Edge and Firefox. I initially tried on Chrome. I am still getting th error. I have not inputted any symbols. I cannot get to any section. When I login, it takes me to releases with the error code below and I cannot click anything else. I tried to start a new registration and that one immediately gives me error code after I get past the initial screen asking for a student name. I am not the only one with the issue. My number is 941-400-6633 if you wish to discuss further. 

 

The following error occurred in the ActionFormService.GetActionFormContent: System.NullReferenceException: Object reference not set to an instance of an object. at Infosnap.Secure.FamilyPortal.Common.Services.FormTemplateService.GetDataEntryFormTemplate(PublishedAction publishedAction, Form form, String culture) at Infosnap.Secure.FamilyPortal.Common.Services.FormTemplateService.RenderDataEntryFormTemplatePage(ActionSession session, Int32 pageNumber, Boolean useRelativeUrl) at Infosnap.Secure.FamilyPortal.Controllers.Services.ActionFormsService.GetActionFormContent(Int32 publishedActionId, String culture, Int32 page)

Highlighted
Senior

Re: ERROR MESSAGE

Hi @jadedavis1013

 

If you are still unable to access the form after following the troubleshooting steps mentioned above, I recommend connecting with our Enrollment support team by clicking on this direct link and they should be able to assist you with this. 



Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!