LTI 1.3 Grade not sync at schoology(invalid format: timestamp)

sunnybaya
Rookie

LTI 1.3 Grade not sync at schoology(invalid format: timestamp)

Hi,

 

I am trying to send a grade from our tool(LTI 1.3) to Schoology but getting an exception I.e 

Unable to complete request: Field value has invalid format: timestamp

Here are the request parameters:-

 


[score_maximum:IMSGlobal\LTI\LTI_Lineitem:private] => 100
[label:IMSGlobal\LTI\LTI_Lineitem:private] => Graded Quiz Companion Reader 2 The Can Score [resource_id:IMSGlobal\LTI\LTI_Lineitem:private] => 6995544715
[tag:IMSGlobal\LTI\LTI_Lineitem:private] => score
[start_date_time:IMSGlobal\LTI\LTI_Lineitem:private] => 2023-10-23T08:17:30Z [end_date_time:IMSGlobal\LTI\LTI_Lineitem:private] => 2023-10-23T08:17:30Z
 
Also, I have used this time format i.e. 2023-10-23T08:17:30+00:00 but still getting the same issue. 
 
Please have a look and let me know if I missed something.
 
5 Replies
sunnybaya
Rookie

Sorry, I missed to send a grade info:-

IMSGlobal\LTI\LTI_Grade {  -score_given: "67"
  -score_maximum: 100
  -comment: null
  -activity_progress: "Completed"
  -grading_progress: "FullyGraded"
  -timestamp: "2023-10-23T11:01:46Z"
  -user_id: "127234017::356ef6f48130aa4da5d98a218d1f5b03"
  -submission_review: null
}

 

ParitoshT
Community Support Expert
Community Support Expert

Hi @sunnybaya,

 

I recommend reviewing this guide that will help you get started with troubleshooting this issue further.

 

Meanwhile, we hope that other community members jump in and share their insights on this.

 

ParitoshT

Community Moderator

hanmari
Hobbyist

Here is the Assessment and Grade Services (AGS) 2.0 documentation on the format of timestamps to be used when sending grades:

 

https://www.imsglobal.org/spec/lti-ags/v2p0#example-of-valid-timestamps

 

It states the following:

 

Timestamp values MUST be formatted using ISO 8601 with a sub-second precision.

Your timestamps do not seem to include the required millisecond property

sunnybaya
Rookie

Hi,

After correcting the timestamp, I think the invalid format: timestamp exception is gone but getting a null response from Schoology, and the grade is still not updated at Schoology's end. 

mikeyoung
Padawan

Hey! Found my way to this thread via Google. If you haven't already figured it out, I was able to see the grade updated on the Schoology end, but Schoology returns a 201 instead of a 204 as suggested by the docs: https://www.imsglobal.org/spec/lti-ags/v2p0#score-publish-service.

In the specs for the API itself, you can see 201 is valid if it's a completely new score being recorded: https://www.imsglobal.org/spec/lti-ags/v2p0/openapi/#/default/Scores.POST.

So you probably have something else going on in terms of not seeing the grade in Schoology. =( What HTTP code response are you getting?