Not receiving email from registration

PowerSchoolEmails
Journeyman

Not receiving email from registration

I can't seem to get my verification email from the registration form. I did get the one for this forum (in my spam folder), but even requesting the registration email to be re-sent results in it never arriving. I can view our mail server logs and it's as if the Powerschool mail server never tries to send the verification email.

Who would I talk to about this, with the power to actually view logs and fix the problem? 

Thanks!

9 Replies
JyotishkaB
Community Support Expert
Community Support Expert

Hi @PowerSchoolEmails 

 

Thank you for reaching out in the Community!  

 

If you have created a Parent Portal account according to the steps listed in the article How do I log into PowerSchool and completed your registration but not receiving emails, there may be an issue on the school or district's end.  We recommend reaching out to the school or district to report the issue since the Parent Portal accounts and enrollment forms are managed and handled at the school district.

Jyotishka B.
Community Moderator



Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

PowerSchoolEmails
Journeyman

Once I get to step 3 "Add your students" and click submit, it says it sends out a verification email from Powerschool.com. However, that email never arrives. Contacting my school will not help. This is a Powerschool registration problem.

 

JyotishkaB
Community Support Expert
Community Support Expert

 

If you are not receiving emails, there may be an email setup issue on the district's end which can be caused due to heavy customization on the PowerSchool page, Gmail failing to sync with the PowerSchool server, etc. That is why we have recommended reaching out to the school or district to report the issue and get the exact reason for not receiving the email. I hope this answers your query.

 

 

Jyotishka B.
Community Moderator



Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

PowerSchoolEmails
Journeyman

So what you'e saying, Jyotishka, is that my account registration email from powerschool.com is actually coming from my school district, even though it's for registration on powerschool.com? Note that this is not the registration at my school, but at powerschool.com.

PowerSchoolEmails
Journeyman

I am unable to edit the reply above, but please do be 100% sure before you answer.

BishalG
Community Support Expert
Community Support Expert

Hi, @PowerSchoolEmails,

 

To help better understand the issue, would you please confirm if the issue is faced on your PowerSchool SIS Parent Portal account (*.powerschool.com/public/home.html or *.yourdistrictportal.com/public/home.html), PowerSchool Mobile app, or PowerSchool Enrollment account (secure.infosnap.com)?

 

Verification emails are generally sent for your Parent Portal account from the school or district's PowerSchool SIS server. 

 

For security reasons, access to the PowerSchool SIS server is available to the school or district. PowerSchool is unable to assist with sign-in, password, or other accessibility-related issues related to your Parent Portal account.



Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
PowerSchoolEmails
Journeyman

Yes, the problem is upon trying to register at myschool.powerschool.com/public

 

BishalG
Community Support Expert
Community Support Expert

Hi, @PowerSchoolEmails,

 

Thank you for your confirmation.

 

That URL belongs to your school or district's Parent Portal account managed by your school or district directly.

 

For security reasons, PowerSchool is unable to assist with sign-in, password, or other accessibility-related issues related to your Parent Portal account.



Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
TravisS
Journeyman

We had some customization on our site that was blocking it. Once we changed the page to default, it started working.