IOS app not synching

New Member

IOS app not synching

I am having a problem with the PowerSchool app on latest iOS not synching. It has been going on for almost a week now. I'm not sure if this is a PowerSchool problem or if it is something that needs to be addressed at the school level.


I have deleted the app and tried to re-install it but when I log in, I get an error that says a server with the specified hostname could not be found. If it helps, my district code is TGLT.


I'd love to know who to contact about this issue. Thanks for the help!

3 Replies

I am also having the same issue, it has been occurring for a few weeks.

Community Moderator
Community Moderator

Hi @ekellyo!


Since you already tried reinstalling the app, I would recommend trying to force the District Code to set. You can do that by performing these steps:


Please try double tapping the home button and closing the app from there. Then, please uninstall the app, turn off your phone for at least 30 seconds, and then reinstall the app.

Then force the district code. After logging out of the mobile app, you should see four boxes on the login screen, this is for the district code. Tap on the link right below the District Code that says “Where is my district code?” on the login screen. On the page that comes up tap “Enter Server Address” and then enter the URL in the box on the next page and hit submit. This is the URL in the web address bar that you see when accessing the web portal.

If you are still experiencing issues after the above steps have been completed, please let me know.


@sdm5In your case, can you provide me with your district code, and let me know if the steps above are helpful for you as well?


Thank you,

Scott S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

Thanks, following those steps got it working.