Cannot upload images (stuck on Processing Image...)


Cannot upload images (stuck on Processing Image...)

Hi there -


For the last few days we have been unable to upload any image - regardless of size. Either to the Content Block "On Page Text" or to "Images gallery". The error looks like this. It just keeps doing this without actually uploading the image. Have tried JPEG, PNG, BMP and JPG. Same result.


It seems to upload a 100% but never ends the processing part.


Is this a known issue? Can someone please help? Thank you.




2 Replies

Hi @skrishna


I am sorry that you are experiencing issues uploading an image to the Content Block on-page text or to the images gallery. 


To help troubleshoot this further, could you please confirm if this occurs only on one system or is it occurring with every system within your district?

Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!


Hi @ElstonS - This issue seems to have now been fixed. Photos/Images are now uploading within content blocks as expected. Shall report back again if issue persists.


Thank you.