Link for Federal survey not working

Highlighted
Padawan

Re: Link for Federal survey not working

Mine is miraculously working all of a sudden. I just tried again and completed it
Highlighted
Padawan

Re: Link for Federal survey not working

Mine did the same thing about 20 minutes after I sent the message.  :)

Highlighted
Community Moderator
Community Moderator

Re: Link for Federal survey not working

Thank you for providing the information!

 

 

To further troubleshoot, we will need to look into each district's site to gather more information.  To protect the privacy of teachers, parents, and students within the district, I recommend connecting with your child's school to share the issues you are experiencing.  The school should be able to connect with PowerSchool Support to further troubleshoot and find a resolution quickly.



Jamie H.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
Highlighted
Trainee

Re: Link for Federal survey not working

Still getting same error

Community Support Expert
Community Support Expert

Re: Link for Federal survey not working

Hi @nildaaz

 

Thank you for reaching out for assistance on the PowerSchool Community!

 

We will need to look into your district's site to gather more information and to protect the privacy of teachers, parents, and students within the district.

 

I recommend reaching out to your school district who will be able to work with PowerSchool Support to help troubleshoot this further and find a resolution for you at the earliest. 



Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!