Special Programs and Progress Report (IEP)

erawley
New Member

Special Programs and Progress Report (IEP)

I am having trouble for my teachers to access marking period one Progress Reports to complete them. I checked the sercurity and they have rights. Please help.

 

Also when we run reports on the SIS side Sped students are not being identified.

Please help this system for IEP's is very frustrating. 

 

Thanks

4 Replies
Reshma
Community Support Expert
Community Support Expert

@erawley 

Thank you for reaching out to the PowerSchool Community!

 

Marking periods are typically handled via a document/section action ran based on information from the cover sheet and data added in the global's profile. We are working with the PowerSchool SpecialEd team to review the issue with marking periods on the Progress report. We will update the thread as soon as possible with further information.

 

In addition, to allow PowerSchool and other Community members to assist, would you please provide the report you are generating that is not identifying students with an IEP status?

 

Please feel free to reach out for further assistance!!



Reshma
PowerSchool Community Support Expert

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
Reshma
Community Support Expert
Community Support Expert

@erawley 

Thank you for your patience while we were working with the PowerSchool SpecialEd team to review the issue with marking periods on the Progress report!

 

The Progress Reports are set by a document/section action, found on the IEP Coversheet. It will perform a series of calculations that base the progress report dates from the Globals and the defined progress report date values there, compared to the IEP meeting date. I recommend making sure that the data being added to the Globals is accurate and error-free.

 

Please feel free to reach out to us with your follow up questions if you have any!



Reshma
PowerSchool Community Support Expert

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
journeyj
Padawan

We also have had many problems with the SPED flag not showing up on the SIS side. Most of time it is a matter of making sure the Census Data drop down information is correct then refreshing the profile. However it does not always work, we are currently troubleshooting ticket for this issue for one student right now.

Reshma
Community Support Expert
Community Support Expert

Hi @journeyj!

 

If you are having issues with the SPED flag not showing up on the SIS side, can you verify the IDT in PowerSchool Special Programs matches the one in PowerSchool SIS?  You would also need to make sure that there is no year gap between the current IEP and today's date, which means the IEP is current.  The student shouldn't be having a SPED Exit date or the SPED Exit date should be a future date.  If the tag shows up in PSSP on the profile after checking these, the Alert export should be exporting the data to PowerSchool SIS.



Reshma
PowerSchool Community Support Expert

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!