Issue whenever I start a new assignment


Issue whenever I start a new assignment

Whenever I start a new assignment, it covers the bar to enter the assignment name with a random list of six previous assignment names and I have to click off to the side to get rid of it. Not a big deal for one assignment. I'm putting in about 40 assignments each for 5 classes, and this gets really, really old and annoying after about the 50th time I hit this delay. It's nearly as annoying as when the mouse moves less than half an inch to the right of the "score entry points" and it pops up a window asking me if I want to save or delete the changes. Both of these make putting in grades an exercise in frustration and wasted time. Once or twice, sure. 200+ times? Problem. There's also no way to use "tab" to go to the next field, so it's mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboarmouse-keyboard-mouse-keyboard-d-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard-mouse-keyboard to enter things in.
Please tell me there is some way to get rid of these features??? I haven't been able to find it, and it's incredibly frustrating, like the programmers deliberately sat and went "oooh, I know!!! Let's make them use their mouse constantly! AND, we'll set it so that if they go just a tiny bit to the side of the box they want to type in, it pops up a window to block them from simply moving the mouse back! Brilliant! This sort of low-level irritation is what we're looking for, there's a bonus in your paycheck for this one!". 😞

2 Replies

Hi @maroongrad,


I am sorry you are having such an experience.


To help assist you, would you please provide the name of the PowerSchool product that you are using?  It should be along the line of PowerSchool SIS, PowerSchool Performance Matters, PowerSchool Learning, etc.

Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
PowerSchool Mentor
PowerSchool Mentor

@maroongrad   Not sure if this will fix some of the issues, but have you tried to clear browser history or using a different  browser. We have noticed recently when using Chrome things don't always work the way they should. 

Heather Weist, MEd
PowerSchool - SIS Administrator, Commonwealth Charter Academy

PowerSchool Mentor/Champion

PowerSchool Mentor of the Year 2021 Winner

PowerSchool Beta Tester of the Year 2022 Winner

Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution. Thanks!