Exporting drop down option

New Member

Exporting drop down option

Hello there! 


Have been having trouble being able to export a report from my existing exporting templates. When I go to export from them the drop down option to select the template is not appearing. It has in the past and nothing has been changed, wondering how to fix this issues. 

4 Replies
Community Support Expert
Community Support Expert

Hi @AleMejia,


Thank you for reaching out to PowerSchool Community!


The Tables appear based on your user role's access to the Students table. If your user role includes access to the Students table, but one or more extended tables are restricted, extended table fields will appear masked on the export.  If the template is not appearing, we recommend making sure that the template wasn't removed by anyone.  If that is not the case, we recommend reaching out to the Designated Support Contacts within your school district who should be able to help you in connecting with the PowerSchool SIS Support team to look into this further.

PowerSchool Community Support Expert

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

Experiencing the same symptoms. Export using Template worked fine but now does not show any drop down options. I have not found any other issues that are not functioning, which would indicate that the role and access are still the same as they were. 


Any ideas anyone?


I believe that I experienced the same issue.  I received noticed that one of our nurses could no longer see anything in their ‘Type of Export:’ drop down box on the Export Using Template screen (Importing & Exporting / Templates for Exporting).  I am new to PowerSchool, but was told that this has been happening and that we need to check which Roles the person belongs to.  So I went to that person’s ‘Security Settings / Admin Access and Roles’ tab.  Under the ‘Roles and Schools’ section, there is a ‘Roles (Group Name)’ column.  I had to click the Edit button (the pencil) and add the ‘Data Export Manager Export / Edit Access (No Group Defined)’ Access Role.  On a side note here, you may have several ‘\\\\’ before the ‘/’.  At some point I had over 20 ‘\’ showing, not sure what that is about.  Once the nurse had this role, they could export.  But by doing this, I gave them full access to exporting the tables because I have not removed any table access from the default Data Export Manager Export Role.   If your organization has created their own Roles, you may have to assign a different role other than the Data Export Manager role that I mentioned above.


I am running into a problem creating a new Data Export Manager Role with less table access.  I created a role and then assigned it to the Nurse security group so that I did not have to assign the new role to every nurse.  If I understand correctly, you cannot assign a Role to a Group that already has members.  I created a new group, was able to assign the new Role, assigned a nurse to the new group, but then the access did not work.  I chatted with support and he could not get it working either.  This issue has been moved up the support ladder.  For now, I am just assigning the default Export role as needed so that the nurses can run their exports.

Carlisle Area School District, PA
K-12, 5100 students, On-Premise: PS
PowerSchool Mentor
PowerSchool Mentor

Recent updates have expanded the level of security controls we can set when it comes to exporting data. I ran into a few users after our most recent update who could no longer export anything.  I had to use Roles Administration to open things back up again for those users.

Doug Skinner

District Instructional Data Officer
Gateway Regional School District

Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution.