Unable to submit reg.


Unable to submit reg.

Two days into this electronic enrollment. Still not able to submit .. erased everything that was allowable to erase and RE-Entered everything multiple times as well as having my wife do the same . Still not having any luck .... y’all might wanna extend the registration dates for the working families .
5 Replies
Community Moderator
Community Moderator

Hello @Adam1041 , thank you for participating in PowerSchool Community!


If you are still having trouble submitting your forms successfully, I would suggest reaching out to our Support team, who will be able to pinpoint the exact error that is preventing you from submitting your form. You can start a Support session here: https://help.powerschool.com/t5/Support-Case-Chat/ct-p/SupportCaseChat


School districts determine the specific time frames that parents have to submit their enrollment forms. If you believe you will need more time to complete the forms, I would suggest reaching out to your school district to let them know. They may be able to provide you with additional time to complete the form.


Please let me know if you have any questions!

New Member


Hi @mona0811,

I am happy to assist you, In order to help you further, would you please elaborate on the difficulty that you are facing when trying to submit your student's enrollment form?  If possible please provide any error message that you may be receiving?

Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
New Member

I am having trouble with registering I am unable to upload any documents but she is attending the same school just online. What do I do? 

Lead Community Moderator
Lead Community Moderator

Enrollment forms can accept all file types and one file can be uploaded per field. If your school or district has enabled the option to upload documents and you are having trouble with uploads, try the steps below:
1. Clear the cache/cookies in your web browser
2. Switch to a different web browser.
3. If you are using a mobile device, try switching to a computer