Create Account button inactive?


Create Account button inactive?

I am trying to create my account in order to register my child for JK. I fill out all the fields correctly and click Create Account and nothing happens. I have tried different browsers, different devices, clearing web history, and different internet access. I can't seem to register him if I can't create an account. Please advise. Thanks.

3 Replies

Hello @acstarkfield,


Can you please which PowerSchool Product you are trying to create an account for your child?  This way we can take a closer look and try to pinpoint the root cause and work towards a resolution.  Thank you!


Nina R.
Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution.


I am not sure what the "product" is.  I am attempting to register my child with the TDSB, Toronto District School Board using a unique link that includes the terms "gosnap" and "snapcode".  I hope that helps to answer address the problem.



Hi @acstarkfield,


Thank you for providing the keywords.  It helped us determine that you are using PowerSchool Enrollment.


There can be a few reasons that would cause the issue.

  • The link to the form could be incorrect or outdated.  Please check the district's website for the most up-to-date information regarding enrollment.  I was able to find some information for TDSB here.
  • Check the fields to make sure that all the Required fields are filled and are in the correct format.
  • If you received a snapcode from the district make sure to use the email associated with the snapcode to register.  A different email address will not work.  You can learn more about snapcodes My Snapcode is Not Working,

If you continue to have difficulty please share a screenshot of the page, without any personal information entered to help troubleshoot further.

Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!