Unable to enroll students in a class

mcortez91
Journeyman

Unable to enroll students in a class

I cannot enroll students into a section/class I created. I get the following message followed by the stundent names. 

 

Not all section enrollment records were created for : 
Unable to create section enrollment record in database

 

Any fixes or ideas???

1 Solution
JeffG9
PowerSchool Champion
PowerSchool Champion

The most common cause of this problem is that the school calendar is not set up. Be sure that there are some In-Session days with a Cycle Day and Bell Schedule set up. PowerSchool will not allow you to enroll students otherwise.

______________
Full Disclosure: I do not work for PowerSchool

View solution in original post

15 Replies
Mattmoody
Journeyman

I am having this same issue, Does anyone have a sollution for this? Im sure there is just somthing that was missed but cant figure out what it is. Thanks in advance. 

JeffG9
PowerSchool Champion
PowerSchool Champion

The most common cause of this problem is that the school calendar is not set up. Be sure that there are some In-Session days with a Cycle Day and Bell Schedule set up. PowerSchool will not allow you to enroll students otherwise.

______________
Full Disclosure: I do not work for PowerSchool
abebell
Journeyman

I am also having this issue, but the calendar is not the problem. This is an existing section that I've successfully added students to on three separate occasions, but I have two new students that I suddenly can't enroll into it.

ParitoshT
Community Support Expert
Community Support Expert

Hi @abebell,

 

Please verify that the term selected at the top of the page is the term in which you would like to create the new section enrollment. Also, please verify that you are entering the correct entry date.

 

If this does not help you then we will require to look into your school setup and will require access to your site. To protect your data privacy I recommend working with the Designated Support Contacts in your school district who should be able to contact the PowerSchool SIS Support team.

 

Paritosh Tyagi
PowerSchool Community Moderator

 

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

josephatureta
Padawan

Hi Abebell,

 

Check to make sure you haven't max-ed out the maximum no of students for that section.

 

Thanks

JWeiswasser
Padawan

if they are maxed out, it asks me for an override password, where would I find that?

JeffG9
PowerSchool Champion
PowerSchool Champion

@JWeiswasser  Setup>District>Miscellaneous>Password requited to override a section's maximum enrollment.

______________
Full Disclosure: I do not work for PowerSchool
JWeiswasser
Padawan

thanks on thanks!

KathleenS32
PowerSchool Champion
PowerSchool Champion

I think that's the problem I'm having. Could it be something in the setting for newly enrolled students... something that is now required from a system upgrade that would've been auto-filled for current students? 

Nititohir
Practitioner

I have problem too.

there many sections for a course . but I can not enroll students to some of them.

the setting for section are the same. only different teacher

 

HeatherWeist
PowerSchool Mentor
PowerSchool Mentor

@Nititohir   Are the sections in a different term? If you are set for current term and trying to enroll a student in a section in a different term, you need to change your term first then do the enrollment. If that is not the case, can you provide a screenshot of the section setup that is working one that is not?


Heather Weist, MEd
PowerSchool - SIS Administrator, Commonwealth Charter Academy

PowerSchool Mentor/Champion

PowerSchool Mentor of the Year 2021 Winner

PowerSchool Beta Tester of the Year 2022 Winner


Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution. Thanks!

Mentors_badgeChampions_badge
anitrabrown07
Padawan

 
jamiem7
Lead Community Moderator
Lead Community Moderator

Thank you for participating in the PowerSchool Community!  @anitrabrown07 


Would you provide more details to your post so we can further assist you with any questions you may have?


Kudos Encourage Participation!
KathleenS32
PowerSchool Champion
PowerSchool Champion

I'm having the same issue with my homeroom class. Easily added students to the first few homerooms, but now having issues mass enrolling students to sections. I've checked the scheduling setup, I'm in the correct term (the year) when trying to add them, and my calendar is set up. Given that I could add students to a few sections yet now am getting that error, as well as being able to each student individually, what am I missing? With just under 800 students and 40 homerooms, the steps that have always worked in the past and are working for some sections should be able to work now and for all sections.

SAFFIYAT
Community Support Expert
Community Support Expert

Hi @KathleenS32

One of the things with mass enrolling students to sections is if one student has an error then it stops the entire mass enrolling process, Example: if we have a student who is pre-registered and you are trying to enroll them into a section with the start date that is before their school's entry date. Then that would cause all the students in that batch not enrolled.

You would need to find out what specific student is having an issue, we recommend you use the binary search algorithm to find out for the student that is blocking the mass enroll and figure out the issue in their record. 

Please let us know in case of further queries.



Saffiya Tasneem
Community Moderator

Remember to give Kudos to suggestions that help you!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!