possible solution to "cannot submit" problem

New Member

possible solution to "cannot submit" problem

Hi Everyone. So for the past two days I have not been able to submit my daughter's app. It kept saying invalid format or something is missing. I rechecked everything at least 10 times but nothing worked. I even read everyone else post and none of the suggestions worked for me. It was very frustrating because I knew that I had filled out everything correctly. Well today I was finally able to submit! I merely just refreshed my page and then boom the "Submit" button turned green for me to be able to sucessfully complete it. Try it out! Hope this info works for you guys.

1 Reply

Hey @aholmes2564,


Thank you for participating in the PowerSchool Community! 


This generally either occurs if the school district had closed the form for maintenance or if there was a required field that is missing information or a field with information entered in an invalid format. 


Thank you for posting this solution for the benefit of other PowerSchool Community Members. We are glad you were able to submit your daughter's enrollment application form. 


Please let us know if you have any follow-up questions.

Elston S.
PowerSchool Community Moderator
Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!