eSchool Plus APP

lvonder
Rookie

eSchool Plus APP

I have used the eSchoolPLUS Family app for the last two years to log into Home Access Center and it is currently not working for anyone in our district. I have no problem logging on to the PC version of eSchool Home Access Center. Any help would be greatly appreciated. 

7 Replies
Susan
Specialist

If the district does not have it enabled you will not be able to get on.  You may want to ask that question.  I know they were having an issue with ios 11.4.1 that they are working on.  Are you getting an error?

lvonder
Rookie

It says:

Login Erro

Invalid username or password.

I am an employee of the district and an admin for our eschool. I have double checked passwords for several different accounts and can see that Home Access Center is enabled for the district. Is there somewhere else I need to go to enable for the app?

Susan
Specialist

Are you using an iPhone?  Is your site hosted?  I have a case in on this issue.  If you are not hosted and not using an iPhone then call it in.  Is HAC enabled for the school as well?  I am able to get in on an iPad.  I haven't tried an adroid.

lvonder
Rookie

Do you have a number to call it into?

joshk
PowerSchool Team
PowerSchool Team

Good afternoon @lvonder!

 

Thank you for your post. If you are having difficulty with the app, the best course of action would be to reach out to your district technical contact to report the error. They should have access to submit a case on your behalf through the case portal in their account. 

 

Best,

JoshK

PowerSchool Community Admin

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
emmasmithh
Rookie

for me it was working smooth on my iPad Pro when it was running on ios 10 however as I have updated to ios 11.3 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?

joshk
PowerSchool Team
PowerSchool Team

Hi @emmasmithh,

 

Thank you for your post! After updating your device, there may be a newer version that you may want to try uninstalling and reinstalling the app with the latest version. If you continue to be unable to access the app after doing so, you will want to report that to your district's technical contact through their IT department. From there they should be able to contact Support directly as needed.

 

Best,

JoshK

PowerSchool Community Admin

 

 

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!