PowerSchool site from App Store not reading the district code to set up

Highlighted
SaydeeRicketts
Journeyman

PowerSchool site from App Store not reading the district code to set up

Trying to open up the PowerSchool parent site on my iPhone and it has me enter the district code which I have checked so many times to be sure it’s correct, that I can’t count. It keeps saying invalid. What is going on?
3 Replies
PowerSchool Team
PowerSchool Team

Re: PowerSchool site from App Store not reading the district code to set up

Good afternoon!

Thank you for your post. There are a couple of troubleshooting steps I would like to look at to better pinpoint the source of your issue. If you are certain of the district code the school has provided, could you please uninstall and reinstall the app on your device to make sure the most recent version has been downloaded? If that does not work, could you please attempt to go through the same process on another device to rule out if it is a hardware issue?

If neither of these steps work, there might be a problem with the district code itself. At that point you will want to reach out to your child’s school to confirm if that is the correct district code. If they can verify the information is correct and it still does not give you access, the building’s IT department may want to work with you to gather information so they can report that issue to our Mobile Support team. To confirm, are you able to successfully view student data through the typical online web browser portal?

Best,
JoshK
PowerSchool Community Admin
Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
SaydeeRicketts
Journeyman

Re: PowerSchool site from App Store not reading the district code to set up

Thank you and yes, I can access it the other way. I tried all these steps and even tried to install on my daughters iPhone too and same problem there. Thanks for your help.
PowerSchool Team
PowerSchool Team

Re: PowerSchool site from App Store not reading the district code to set up

Good morning @SaydeeRicketts!

 

Thank you for providing that update. In that case you will want to report that to your child's school and have their IT department take a look at the mobile configuration. The district may eith er have it disabled at this time or will want to do some troubleshooting it has been activated for parents. If you have any screenshots you would be willing to share with them of the app not showing what is in the web portal should help them better investigate, just make sure to redact any sensitive information in the screenshot before doing so.

 

Best,

JoshK

PowerSchool Community Admin

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!