Standards-based gradebook is so slow its nearly unusable

cdolson1
New Member

Standards-based gradebook is so slow its nearly unusable

Over the past month, the standards-based gradebook has begun to opperate so slowly when I try to put in grades that I almost can't justify the time it takes to input the grades. When I enter a measurement on the main page of the gradebook, the little spinning dots come up and stick around for at least 15 seconds sometimes more like a minute. That's for EACH measurement I enter. I have tried clicking the different options that come up like "save what I've entered" but that just seems to end up entering multiple measurements.

 

Is this because I have a personal account left over from before Haikuclassroom was bought out so I don't have a school district managing my account? 

1 Reply
PowerSchool Team
PowerSchool Team

Re: Standards-based gradebook is so slow its nearly unusable

Good afternoon @cdolson1!

 

Thank you for posting in our Community. We are sorry to hear you have been experiencing slowness in your Standards-Based Gradebook over the past month. While we have not received widespread reports of slowness for our Standards-Based Gradebook feature, we did report slow load times and errors across PowerSchool Learning this weekend. You can see the update and our current status here: http://status.haikulearning.com/. This may be a contributing factor to what you were seeing.

If your experience is not specific to this time frame, and you have had slowness prior to this weekend, we would like to gather the following information from you to better assist you with your inquiry:

- Is this something you are seeing in other features or just your Standards-Based Gradebook?
- Is this happening in a class that has a particularly high number of students or standards?
- Do you have any background data, such as removed students from past terms or years? You can see info on removed students here.
- Has anything changed in your class set up or network connection over the past month?
- Have you attempted to enter standards using your login credentials on another machine?

These are some general things to look for. If this is a persistent issue that is not related to our status update or the items above, our support team will be happy to look into your specific instance further. Please see our article on how to get additional help and we will be happy to take a look.

 

Best,

JoshK

PowerSchool Community Moderator

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!