Register Link on Power School Learning

caseyjohnson7
Recruit

Register Link on Power School Learning

I have a solo teacher account. When my students try to "register," the link does not work.  Suggestions?

59 Replies
MarkD
Hobbyist

I tried it the morning and met with success  !!!  Happily. 

 

Thanks,

 

Mark

joshk
PowerSchool Team
PowerSchool Team

@MarkD,

 

That is wonderful to hear, I am glad you were able to register your students! I encourage the rest of the Community to also let us know as you are able if you were successful as well! If for any reason that is not the case, please let us know that as well so we can take a closer look as needed.

 

Best,

JoshK

PowerSchool Community Admin 

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
BlueRio
Hobbyist

Thank you!

BlueRio
Hobbyist

I agree - I have something like 7 classes I teach - I realize I am not a big customer or theirs - but seriously this is enough to make me want to take EVERYTHING I have and switch - which will cost me HOURS and maybe thousands of of dollars in actual cost and time spent. I am disgusted!!! I have been with this system since 2013!!!!!!!!

kvillanu
Journeyman

I've been trying to register my students for 2 weeks.  I was able to register 3 of them this morning and now I am getting prompted for the kids to create a solo teacher account after they put in the code that I generate.  I need this up and running NOW.  Please, help!

aharkins
Recruit

I am having the same issues....it's so frustrating!!!!

SimonSaysInspire

Same thing is happening here, is it my error or PowerSchool?

joshk
PowerSchool Team
PowerSchool Team

Good morning all,

 

I am sorry to hear you have been experiencing difficulty with registering students and that has led to some frustration. The following workaround was shared by @sthomaschek as a workaround:

 

When you get to the login screen with the blue "Register" link, do the following:

 

  • Hold down CTRL, SHIFT and press the letter “I”
  • Click the Console tab
  • Enter the command below then press enter

Element.toggle('new_account')

 

If you are experiencing difficulties with registration by the traditional means, I highly encourage you to reach out to your IT department if you are a teacher and share any screenshots of errors as they occur so they can better report those problems to Registration Support. If you are part of the technology team at your school, you will want to submit a case to Registration Support, including as much detail as possible. The team will provide updates on any fixes or be able to offer further guidance as needed.

 

Best,

JoshK

PowerSchool Community Admin 

Remember to give Kudos to suggestions that help you! If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!
BlueRio
Hobbyist

I have no idea if this was a fluke. I tried one browser and could not even get to the registration button. I tried Safari (which had not worked before) and suddenly it prepopulated for my student. I took a chance and created a username for her and password - and hopefully she is now in. I am actually hoping this is NOT a fluke and the issue has now been fixed? 

BlueRio
Hobbyist

What if we are Power Learning Solo Teachers? I have no tech team. Also this work around - is this a PC only work around or does it work on MACs - how much longer must we wait for a solution? I get that technology can be challenging - yet this is something that literally must be affecting HUNDREDS of users?

Thank you,

Jessi