attendance screen loading

jlehde
Journeyman

attendance screen loading

When taking attendance, has any else had issues with the page taking 15 to 20 seconds to load each time? I am going on week 3 of this occurring. I only notice this when taking attendance. 

11 Replies
jlehde
Journeyman

I should note this is only on the taking attendance by seating chart icon. Taking attendance with the list does not take a while to load. 

HeatherWeist
PowerSchool Champion
PowerSchool Champion

@jlehde  Few suggestions...clear browser history, try a different web browser. I've noticed when working with seating charts things tend to run a little slower. I think it might have to do with the amount of extra data that is required to render that page. For example, pictures, diagram placements, etc. 


Heather Weist, M.S.E
PowerSchool Specialist, Westside Community Schools, Omaha, NE (K-12, ~6000 students)

PowerSchool Mentor/Champion



Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution. Thanks!
jlehde
Journeyman

Thanks for the suggestions. I cleared everything, updated my computer with a restart, and tried different browsers. Unfortunately, I am still having the same issue. 

Jennifer_G
PowerSchool Champion
PowerSchool Champion

Yes, we are noticing the same thing in our district. We are seeing 10-12 seconds of initial load time as the page renders. Near as I can tell, it began after updating to 21.4.4 (possibly earlier) and it seems to still be an issue on 21.4.5 as well, though I only have that version on our test server at the moment. Not browser specific .. same performance on Chrome/Firefox/Edge .. and disabling customizations did not impact the behavior. Other attendance pages load quickly (1 second max) - it is only an issue with the Seating Chart view. I did report the issue to support today, but they do not currently have any other tickets with similar issues. They were able to replicate the issue on their network, but speculated it is only the necessary time taken to fully render the page. Nothing has changed on that side for us from previous years (number of images per class, size of the image files, etc.), so I am unsure why page load time would have doubled? 

KritiS
Community Support Expert
Community Support Expert

Hi @jlehde 

 

Would you kindly confirm that you are experiencing this problem while utilizing the connection at school, at home, or on your mobile device? Or if the performance problem occurs across all connections?

 

 



KritiS
Community Moderator

Remember to give Kudos to suggestions that help you!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
jlehde
Journeyman

I experience this across all connections. My thought was the school wifi wasn't very good, then I tried at home and still experienced the same issue. I have not tried on my mobile device. 

NinaRi
Community Support Expert
Community Support Expert

Hi @jlehde

 

Thank you for your post in the PowerSchool Community!

 

Can you confirm that you have updated to PowerSchool version : 21.4.5.0?  If not, can you perform the PowerSchool update and let us know if the issue continues to persist after doing so.  Also, have you attempted to move any plug-ins and other applications while taking attendance?

 

If the issue continues to persist after following the troubleshooting steps above, we suggest working with your school's Designated Support Contact(s). They will be able to assist you with further troubleshooting or submit a ticket on your behalf to the PowerSchool SIS Support team for investigation. 


Nina R.
Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution.
jlehde
Journeyman

We are on version 21.4.5.0. It seems to be a PoweSchool issue. 

BishalG
Community Support Expert
Community Support Expert

Hi @jlehde,

 

As Heather mentioned, a few seconds of delay can likely be caused due to the PowerSchool SIS hosted system (not your computer) working on rendering the pictures and images on the page.

 

If the system is taking too long, it could be caused due to customizations set up on the district's end.  In that case, you will want to contact the district's Designated Support Contacts or your PowerSchool SIS Administrator, who can work with PowerSchool SIS support to determine the cause.



Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!
NinaRi
Community Support Expert
Community Support Expert

Hi @Jennifer_G,

 

Thank you for providing these details in the PowerSchool Community! The Support engineer working on this case has reached out to you via the open ticket to schedule a call. If you are not seeing those updates through your case, please let us know.  The engineer would like to schedule a call based on your avaiablity to investigate this issue.  If you can let them know your availability through the ticket, they will be happy to look into this issue with you.  

 

Please let us know if you have any questions. 

 


Nina R.
Did your issue get solved? Please remember to give Kudos and/or select Accept As Solution on the helpful posts to thank the author and to help others find the solution.
Jennifer_G
PowerSchool Champion
PowerSchool Champion

@NinaRi, thanks! I do not have an open ticket for this. I reported it primarily so the possible issue was documented, with the understanding that it may not be a bug. After talking through the behavior with support, we opted to close the case rather than escalate it, since there weren't really any other reports of the behavior. I just checked the case and it is still closed. I'd be happy to work with support if that would be useful to them, though-- happy to share what we are currently seeing. I'll keep an eye on the case for any updates or comments.

 

Side note: we updated to 21.4.5.0 last night and it's still taking exactly 11 seconds to load the seating chart view. Not the end of the world by any means, but noticeably slower performance than previous years.