Professional learning course restriction is not working

audrey737
Rookie

Professional learning course restriction is not working

I am having an issue when creating a professional learning course. I have the demographics for the course set to restricted, so only administrators in our district can access the course. Once the course was approved and published for registration, we discovered the restriction is not working and is allowing all staff to sign up for the course. Is there a setting I am missing when creating the class that will make this restriction happen? 

5 Replies
ParitoshT
Community Support Expert
Community Support Expert

Hi @audrey737,

 

Thank you for posting your question in the Community.

 

You might want to open your course and then follow the listed steps.

 

* Click on ''Set Restricted''

 

* Click on ''Administrator'' under Role

 

* Then check the checkbox for ''Administrators'' and Save.

 

After that Administrator should come up under your Demographics column and you should be good to go.

 

Please let me know if this helps.

 

ParitoshT

Community Moderator 

 

Remember to give Kudos to suggestions that help you!
If another user helps solve your issue, please select Accept As Solution on their post so others can see the solution, too!

audrey737
Rookie

Hello @ParitoshT ,

 

I followed those steps when setting up the course. However, once the course was approved, with that restriction and published, the restriction is not limiting who can sign up for the course. Is there another setting I am missing to restrict the course to a specific group once it is a published course? 

 

 

ParitoshT
Community Support Expert
Community Support Expert

Hi @audrey737,

 

Thank you for your response. 

 

I see that the restrictions have been setup properly for Course No. 10075. I could assume the identity of a normal user and was not able to find the course and when I assumed the identity of an Administrator the I was able to find the course which means the restrictions are setup correctly. 

 

If you still continue to face the issues then I recommend reaching out to your Super User.

 

ParitoshT

Community Moderator 

audrey737
Rookie

Thank you! We discovered we needed to select the PM_Administrator and PM_Principal for the restriction to work. If we just select Administrator from the list, the restriction is not there.  

 

I have another issue.....

 

When I am creating an Instructor Led Course, type all of the information in the fields and hit SAVE, not all of the information is showing up on the Manage Instructor Led Course page. Then when I go back in to edit the course, those fields are blank. I add the information again and hit save. The information disappears. This is happening in the following fields: Text and Reading, Administrator Pathway, Grading and Participation, Target Audience, and Align Goals. Is there a setting I am missing for these fields to appear on the Manage Instructor Led Course page? OR is this a setting my Super User needs to change? 

 

Audrey

BishalG
Community Support Expert
Community Support Expert

Hi @audrey737,

 

There can be multiple reasons behind the fields not being saved. We recommend reporting the issue to your district's Designated Support Contact who can work with PowerSchool Professional Learning support towards a solution.



Bishal G.
PowerSchool Community Support Expert
Say Thanks by clicking the thumbs up icon in a post!
If a suggestion helps solve your issue, please select Accept As Solution on the post so others can see the solution, too!